diff mbox series

[bug#62441,1/4] gnu: Add r-ctrialsgov.

Message ID 20230325174555.837323-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62441,1/4] gnu: Add r-ctrialsgov. | expand

Commit Message

Mădălin Ionel Patrașcu March 25, 2023, 5:45 p.m. UTC
* gnu/packages/cran.scm (r-ctrialsgov): New variable.
---
 gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: de84b24613afa4020f3f0553dad8e39a78d1f92c

Comments

Ricardo Wurmus March 26, 2023, 5:01 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-ctrialsgov): New variable.

We worked on the same patches at the same time.  I pushed this series
yesterday.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a36c845479..a3590fe9cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -396,6 +396,43 @@  (define-public r-cplm
 comparison tool involving zero-inflated and highly skewed distributions.")
     (license license:gpl2+)))
 
+(define-public r-ctrialsgov
+  (package
+    (name "r-ctrialsgov")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ctrialsgov" version))
+       (sha256
+        (base32 "0hdh1fdfaja8amf7fkvk1c6yif703132bvacq0j9pk5jr97czgpw"))))
+    (properties `((upstream-name . "ctrialsgov")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-dbi
+           r-dplyr
+           r-ggplot2
+           r-htmlwidgets
+           r-lubridate
+           r-matrix
+           r-plotly
+           r-purrr
+           r-rlang
+           r-stringi
+           r-tibble))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=ctrialsgov")
+    (synopsis
+     "Query data from U.S. National Library of Medicine's Clinical trials database")
+    (description
+     "The ctrialsgov package implements a series of tools which create and query
+database from the United States National Library of Medicine's Clinical trials
+database @url{https://clinicaltrials.gov/}.  Functions provide access a variety
+of techniques for searching the data using range queries, categorical filtering,
+and by searching for full-text keywords.  Minimal graphical tools are also
+provided for interactively exploring the constructed data.")
+    (license license:expat)))
+
 (define-public r-curry
   (package
     (name "r-curry")