diff mbox series

[bug#62428]

Message ID 20230324231900.28367-4-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62428] | expand

Commit Message

Mădălin Ionel Patrașcu March 24, 2023, 11:18 p.m. UTC
Date: Fri, 24 Mar 2023 00:51:48 +0100
Subject: [PATCH 04/14] gnu: Add r-apalyzer.

* gnu/packages/bioconductor.scm (r-apalyzer): New variable.
---
 gnu/packages/bioconductor.scm | 45 +++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c58613bea3..3ae0dba919 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9354,6 +9354,51 @@  (define r-rcppnumerical
 @code{Rcpp}.")
    (license license:gpl2+)))
 
+(define-public r-apalyzer
+  (package
+    (name "r-apalyzer")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "APAlyzer" version))
+       (sha256
+        (base32 "1iaz9ircfh5x3z5pibn5vnd4lbbr7m5ypk97xnizn22z41aqrxn3"))))
+    (properties `((upstream-name . "APAlyzer")))
+    (build-system r-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+         (add-before 'install 'change-home-dir
+           (lambda _
+             ;; Change from /homeless-shelter to /tmp for write permission.
+             (setenv "HOME" "/tmp"))))))
+    (propagated-inputs
+     (list r-deseq2
+           r-dplyr
+           r-genomicalignments
+           r-genomicfeatures
+           r-genomicranges
+           r-ggplot2
+           r-ggrepel
+           r-hybridmtest
+           r-repmis
+           r-rsamtools
+           r-rsubread
+           r-rtracklayer
+           r-summarizedexperiment
+           r-tidyr
+           r-variantannotation))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/RJWANGbioinfo/APAlyzer/")
+    (synopsis "Toolkit for APA analysis using RNA-seq data")
+    (description
+     "The APAlyzer package performs @acronym{3'UTR, Three Prime Untranslated
+Region} @acronym{APA, Alternative polyadenylation}, Intronic APA and gene
+expression analysis using RNA-seq data.")
+    (license license:lgpl3)))
+
 (define-public r-apeglm
   (package
    (name "r-apeglm")