diff mbox series

[bug#62350,1/2] gnu: python-typing-extensions: Update to 4.5.0.

Message ID 20230321192025.101040-1-code@greghogan.com
State New
Headers show
Series Update python-numpy-next. | expand

Commit Message

Greg Hogan March 21, 2023, 7:20 p.m. UTC
See https://github.com/python/typing/tree/master/typing_extensions for
notice about repository change.

* gnu/packages/python-xyz.scm (python-typing-extensions): Update to 4.5.0.
[source]: Update repository URL.
[arguments](%standard-phases): Remove 'enter-source-directory'.
---
 gnu/packages/python-xyz.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac10290237..e3778b0a44 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22533,26 +22533,23 @@  (define-public python-typeguard
 (define-public python-typing-extensions
   (package
     (name "python-typing-extensions")
-    (version "4.0.1")
+    (version "4.5.0")
     (source (origin
               ;; The test script is missing from the PyPI archive.
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/python/typing")
+                    (url "https://github.com/python/typing_extensions")
                     (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0a35fh5wk9s538x0w3dz95y0avnhd2srzyv9s1a372711n8hdl4p"))))
+                "1fymg0hirbmv51avwv17s426hi8bwg0pq8yjci1n7qzr2p3dp3my"))))
     (build-system python-build-system)
     (arguments
      (list
       #:tests? #f       ;requires Python's test module, not available in Guix
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'enter-source-directory
-            (lambda _
-              (chdir "typing_extensions")))
           ;; XXX: PEP 517 manual build copied from python-isort.
           (replace 'build
             (lambda _