diff mbox series

[bug#62196,005/223] gnu: ruby-standard: Update to 1.25.2

Message ID 20230320171635.11184-5-maxim.cournoyer@gmail.com
State New
Headers show
Series None | expand

Commit Message

Maxim Cournoyer March 20, 2023, 5:12 p.m. UTC
* gnu/packages/ruby.scm (ruby-standard): Update to 1.25.2.
[arguments]: Delete trailing #t.  Update comment.
---
 gnu/packages/ruby.scm | 16 +++++++---------
 1 file changed, 7 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4ed760cfd6..981a5912f2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1730,7 +1730,7 @@  (define-public ruby-stud
 (define-public ruby-standard
   (package
     (name "ruby-standard")
-    (version "0.4.7")
+    (version "1.25.2")
     (source
      (origin
        (method git-fetch)               ;no test suite in distributed gem
@@ -1740,22 +1740,20 @@  (define-public ruby-standard
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0ylx0lm2pbbgr5h7fban592w96bl3wxmvfcpcdfrhkxnpg5kiwgv"))))
+         "0c0lsrvdl224s8166xrk9ibm19wbzn5l9s27cm7bjn0jr81j6agk"))))
     (build-system ruby-build-system)
     (arguments
-     ;; TODO: the tests are currently broken due to using a newer Rubocop.
+     ;; TODO: the tests are currently broken due to using a different Rubocop
+     ;; version.
      `(#:tests? #f
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'relax-version-requiremens
            (lambda _
              (delete-file "Gemfile")
-             (delete-file "Gemfile.lock")
-             #t)))))
-    (native-inputs
-     (list ruby-gimme ruby-pry ruby-simplecov))
-    (propagated-inputs
-     (list ruby-rubocop ruby-rubocop-performance))
+             (delete-file "Gemfile.lock"))))))
+    (native-inputs (list ruby-gimme ruby-pry ruby-simplecov))
+    (propagated-inputs (list ruby-rubocop ruby-rubocop-performance))
     (synopsis "Ruby Style Guide, with linter & automatic code fixer")
     (description "Standard is a port of StandardJS.  Like StandardJS, it aims
 to save time in the following ways: