diff mbox series

[bug#62228,v2,2/3] gnu: Add halibut.

Message ID 20230317082910.25037-2-sarg@sarg.org.ru
State New
Headers show
Series [bug#62228,v2,1/3] gnu: Prefix licenses in documentation.scm | expand

Commit Message

Sergey Trofimov March 17, 2023, 8:29 a.m. UTC
* gnu/packages/documentation.scm (halibut): New variable.
---
 gnu/packages/documentation.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 3a6e9b10fb..10e607d430 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -235,6 +235,33 @@  (define-public doxygen
 and to some extent D.")
     (license license:gpl3+)))
 
+(define-public halibut
+  (package
+    (name "halibut")
+    (version "1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://www.chiark.greenend.org.uk/~sgtatham/halibut/halibut-"
+                    version "/halibut-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ciikn878vivs4ayvwvr63nnhpcg12m8023xv514zxqpdxlzg85a"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ;No tests.
+    (native-inputs (list pkg-config perl))
+    (home-page "https://www.chiark.greenend.org.uk/~sgtatham/halibut/")
+    (synopsis "Documentation production system for software manuals")
+    (description
+     "Halibut is a text formatting system designed primarily for writing software
+documentation.  It accepts a single source format and outputs any combination of
+plain text, HTML, Unix man or info pages, PostScript or PDF.  It has extensive
+support for indexing and cross-referencing, and generates hyperlinks within output
+documents wherever possible.  It supports Unicode, with the ability to fall back to
+an alternative representation if Unicode output is not available.")
+    (license license:expat)))
+
 (define-public doc++
   (package
     (name "doc++")