diff mbox series

[bug#62228,v2,1/3] gnu: Prefix licenses in documentation.scm

Message ID 20230317082910.25037-1-sarg@sarg.org.ru
State New
Headers show
Series [bug#62228,v2,1/3] gnu: Prefix licenses in documentation.scm | expand

Commit Message

Sergey Trofimov March 17, 2023, 8:29 a.m. UTC
* gnu/packages/documentation.scm: Prefix licenses.
---
 gnu/packages/documentation.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index a372e1a6ca..3a6e9b10fb 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -29,7 +29,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages documentation)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix gexp)
@@ -102,7 +102,7 @@  (define-public latex2html
     (description "LaTeX2HTML is a utility that converts LaTeX documents to web
 pages in HTML.")
     (home-page "https://www.latex2html.org/")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public asciidoc
   (package
@@ -178,7 +178,7 @@  (define-public asciidoc
 AsciiDoc is highly configurable: both the AsciiDoc source file syntax and
 the backend output markups (which can be almost any type of SGML/XML
 markup) can be customized and extended by the user.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-deprecated asciidoc-py3 asciidoc)
 
@@ -233,7 +233,7 @@  (define-public doxygen
 programming languages such as C, Objective-C, C#, PHP, Java, Python,
 IDL (Corba, Microsoft, and UNO/OpenOffice flavors), Fortran, VHDL, Tcl,
 and to some extent D.")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public doc++
   (package
@@ -258,7 +258,7 @@  (define-public doc++
 generate both TeX output for high-quality hardcopies or HTML output for online
 browsing.  The documentation is extracted directly from the C/C++/IDL source
 or Java class files.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public pod2pdf
   (package
@@ -284,7 +284,7 @@  (define-public pod2pdf
 Documentation} format to PDF files.  It also supports some extensions to the POD
 format, and supports the file types JPG, GIF, TIFF, PNG, and PNM for embedded
 objects.")
-    (license artistic2.0)))
+    (license license:artistic2.0)))
 
 (define-public python-docrepr
   (package
@@ -335,7 +335,7 @@  (define-public python-docrepr
     (description "Docrepr renders Python docstrings to HTML with Sphinx.  It
 can generate rich and plain representations of docstrings, alongside
 additional metadata about the object to which the docstring belongs.")
-    (license bsd-3)))
+    (license license:bsd-3)))
 
 (define-public scrollkeeper
   (package
@@ -368,7 +368,7 @@  (define-public scrollkeeper
 provides a simple API to allow help browsers to find, sort, and search the
 document catalog.  It will also be able to communicate with catalog servers on
 the Net to search for documents which are not on the local system.")
-    (license lgpl2.1+)))
+    (license license:lgpl2.1+)))
 
 (define-public zeal
   (let ((commit "d3c5521c501d24050f578348ff1b9d68244b992c")
@@ -416,4 +416,4 @@  (define-public zeal
       (synopsis "Offline documentation browser inspired by Dash")
       (description "Zeal is a simple offline documentation browser
 inspired by Dash.")
-      (license gpl3+))))
+      (license license:gpl3+))))