diff mbox series

[bug#61933,vREVISION,8/9] gnu: Add r-hgnchelper.

Message ID 20230303130723.88484-8-navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** A requested with 8 dependencies *** | expand

Commit Message

nafkhamdc March 3, 2023, 1:07 p.m. UTC
* gnu/packages/bioinformatics.scm (r-hgnchelper): New variable.
---
 gnu/packages/bioinformatics.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 42d0923ab1..b179fcb61a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9139,6 +9139,29 @@  (define-public r-archr
        "This package is designed to streamline scATAC analyses in R.")
       (license license:gpl2+))))
 
+(define-public r-hgnchelper
+  (package
+    (name "r-hgnchelper")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "HGNChelper" version))
+              (sha256
+               (base32
+                "0qwkk5658j4j6w2wgvxkp38cyvscjp93d3zc7gb97vcihqx0ngxa"))))
+    (properties `((upstream-name . "HGNChelper")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/waldronlab/HGNChelper")
+    (synopsis
+     "Identification and correction of invalid gene symbols for human and mouse")
+    (description
+     "Set of R functions for identifying and correcting HGNC human gene symbols.
+In addition, you can identify MGI mouse gene symbols, which have been converted
+to date format by Excel, withdrawn, or aliased.  Also contains functions for
+reversibly converting between HGNC symbols and valid R names.")
+    (license license:gpl2+)))
+
 (define-public r-icellnet
   ;; v1.0 tagged in 2020, last commit contains many fixes.
   ;; DESCRIPTION says Version: 0.0.0.9000.