diff mbox series

[bug#61933,vREVISION,7/9] gnu: Add r-tictoc.

Message ID 20230303130723.88484-7-navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** A requested with 8 dependencies *** | expand

Commit Message

nafkhamdc March 3, 2023, 1:07 p.m. UTC
* gnu/packages/bioinformatics.scm (r-tictoc): New variable.
---
 gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 14efaa9570..42d0923ab1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8960,6 +8960,28 @@  (define-public r-snapatac
 single cell ATAC-seq sequencing data.")
     (license license:gpl3)))
 
+(define-public r-tictoc
+  (package
+    (name "r-tictoc")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "tictoc" version))
+              (sha256
+               (base32
+                "0ka7zd857xfqb5afn0psn0yzfv2qjb0ddxfyiq6aggbnla5qc3qj"))))
+    (properties `((upstream-name . "tictoc")))
+    (build-system r-build-system)
+    (home-page "https://github.com/jabiru/tictoc")
+    (synopsis
+     "Functions for timing R scripts and implementations of stack and list structures")
+    (description
+     "The tictoc package provides the timing functions tic and toc that can be nested.
+It provides an alternative to @code{system.time()} with a different syntax similar to
+that in another well-known software package. tic and toc are easy to use, and are
+especially useful when timing several sections in more than a few lines of code.")
+    (license license:asl2.0)))
+
 (define-public r-tsis
   (let ((commit "24460298fbe1d26e4da390f6e4f3d4d9d62334dc")
         (revision "1"))