diff mbox series

[bug#61854]

Message ID 20230228001030.2658-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61854] | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 28, 2023, 12:10 a.m. UTC
Date: Tue, 28 Feb 2023 01:07:34 +0100
Subject: [PATCH] gnu: Add r-chromomap.

* gnu/packages/cran.scm (r-chromomap): New variable.
---
 gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 9ae4846c502b75867b83180bb65d422ff838e4e6

Comments

Ricardo Wurmus March 2, 2023, 12:27 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> Date: Tue, 28 Feb 2023 01:07:34 +0100
> Subject: [PATCH] gnu: Add r-chromomap.
>
> * gnu/packages/cran.scm (r-chromomap): New variable.

Applied with commit a7763e067d86908210758aab80d33e4f8b815b1c.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c80e98134a..5af741674c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -306,6 +306,42 @@  (define-public r-changepoint
     ;; Any version of the GPL.
     (license license:gpl3+)))
 
+;; The package sources include multiple non-mified js and v5.1.0 variant of d3.js
+;; The d3.js file is also non-minified and the file mention the version and the
+;; home-page.
+(define-public r-chromomap
+  (package
+    (name "r-chromomap")
+    (version "4.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "chromoMap" version))
+       (sha256
+        (base32 "1067h5d6jdbm811n7ayikhqfbcqmxbz5jgp05vf1sbln7qgn9l43"))))
+    (properties `((upstream-name . "chromoMap")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-htmltools r-htmlwidgets))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=chromoMap")
+    (synopsis "Interactive genomic visualization of biological data")
+    (description
+     "This package provides interactive, configurable and graphics visualization
+of the chromosome regions of any living organism allowing users to map chromosome
+elements (like genes, SNPs etc.) on the chromosome plot.  It introduces a special
+plot viz. the \"chromosome heatmap\" that, in addition to mapping elements, can
+visualize the data associated with chromosome elements (like gene expression) in
+the form of heat colors.  Users can investigate the detailed information about the
+mappings (like gene names or total genes mapped on a location) or can view the
+magnified single or double stranded view of the chromosome at a location showing
+each mapped element in sequential order.  The package provide multiple features
+like visualizing multiple sets, chromosome heat-maps, group annotations, adding
+hyperlinks, and labelling.  The plots can be saved as HTML documents that can be
+customized and shared easily.  In addition, you can include them in R Markdown or
+in R Shiny applications.")
+    (license (list license:gpl3
+                   license:isc )))) ;; for d3 bundled js
+
 (define-public r-collections
   (package
     (name "r-collections")