diff mbox series

[bug#61818,09/14] gnu: Add rust-rental-impl.

Message ID 20230226170928.9407-9-steve@futurile.net
State New
Headers show
Series [bug#61818,01/14] gnu: Add rust-ogg-sys. | expand

Commit Message

Steve George Feb. 26, 2023, 5:09 p.m. UTC
* gnu/packages/crates-io.scm (rust-rental-impl): New variable.
---

 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e4aed24782..c1bdbf22a6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46699,6 +46699,30 @@  (define-public rust-remove-dir-all-0.5.2
        #:cargo-development-inputs
        (("rust-doc-comment" ,rust-doc-comment-0.3))))))
 
+(define-public rust-rental-impl-0.5
+  (package
+    (name "rust-rental-impl")
+    (version "0.5.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rental-impl" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1pj0qgmvwwsfwyjqyjxzikkwbwc3vj7hm3hdykr47dy5inbnhpj7"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build? #f
+        #:cargo-inputs
+        (("rust-proc-macro2" ,rust-proc-macro2-1)
+         ("rust-quote" ,rust-quote-1)
+         ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/jpernst/rental")
+    (synopsis "Implementation details of the rust-rental crate")
+    (description "Implementation details for the rust-rental crate.
+Should not be used directly.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-reopen-0.3
   (package
     (name "rust-reopen")