diff mbox series

[bug#61818,05/14] gnu: Add rust-librespot-tremor.

Message ID 20230226170928.9407-5-steve@futurile.net
State New
Headers show
Series [bug#61818,01/14] gnu: Add rust-ogg-sys. | expand

Commit Message

Steve George Feb. 26, 2023, 5:09 p.m. UTC
* gnu/packages/crates-io.scm (rust-librespot-tremor): New variable.

---
Had to set the package to skip build. It errors saying rust-ogg-sys
can't be built, but it does. Unsure how to debug or fix.

 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 257f35e147..626dfafa8e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30681,6 +30681,32 @@  (define-public rust-libradicl-0.4
 single-cell and single-nucleus sequencing data.")
     (license license:bsd-3)))
 
+(define-public rust-librespot-tremor-0.2
+  (package
+    (name "rust-librespot-tremor")
+    (version "0.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "librespot-tremor" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1zmld16zawvn7ayrf318lwdr2d7awn4bk9s0d6kpim0mz6zjbxcp"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build? #t ; errors building ogg-sys - though ogg-sys builds
+        #:cargo-inputs
+        (("rust-libc" ,rust-libc-0.2)
+        ("rust-ogg-sys" ,rust-ogg-sys-0.0.9))
+        #:cargo-development-inputs
+        (("rust-cc" ,rust-cc-1)
+        ("rust-pkg-config" ,rust-pkg-config-0.3))))
+    (home-page "https://github.com/librespot-org/librespot-tremor")
+    (synopsis "Rust bindings for Tremor, a fixed point Vorbis decoder")
+    (description "Rust bindings for Tremor, a fixed point decoder for the
+Vorbis audio format.  Used by platforms that can't do floating point maths.")
+    (license license:expat)))
+
 (define-public rust-libsqlite3-sys-0.23
   (package
     (name "rust-libsqlite3-sys")