diff mbox series

[bug#61815,2/2] gnu: Add pandoc-include.

Message ID 20230226153138.22696-1-wz@freeshell.de
State New
Headers show
Series [bug#61815,1/2] gnu: Add python-panflute. | expand

Commit Message

Wiktor Żelazny Feb. 26, 2023, 3:31 p.m. UTC
* gnu/packages/textutils.scm (pandoc-include): New variable.
---
 gnu/packages/textutils.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index fad790c065..e03ea3d448 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1551,3 +1551,31 @@  (define-public python-panflute
 write.  It is a pythonic alternative to John MacFarlane's pandocfilters, from
 which it is heavily inspired.")
     (license license:bsd-3)))
+
+(define-public pandoc-include
+  (package
+    (name "pandoc-include")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pandoc-include" version))
+              (sha256
+               (base32
+                "01nrbzs85mrd7jcflicsz0bmfnzi6wsy0ii262xl01zsabqd7n91"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-natsort python-panflute))
+    (home-page "https://github.com/DCsunset/pandoc-include")
+    (synopsis "Pandoc filter to allow file and header includes")
+    (description "@code{pandoc-include} extends Pandoc to support:
+
+@enumerate
+@item include as raw blocks
+@item indent and dedent included contents
+@item partial include
+@item code include
+@item Unix style pathname
+@item recursive include
+@item Yaml header merging
+@item header include
+@end enumerate")
+    (license license:expat)))