diff mbox series

[bug#61815,1/2] gnu: Add python-panflute.

Message ID 20230226152351.22119-1-wz@freeshell.de
State New
Headers show
Series [bug#61815,1/2] gnu: Add python-panflute. | expand

Commit Message

Wiktor Żelazny Feb. 26, 2023, 3:23 p.m. UTC
* gnu/packages/textutils.scm (python-panflute): New variable.
---
 gnu/packages/textutils.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 53a739ae5d05c3278f09e05f0cba13d698031d92

Comments

Ludovic Courtès June 8, 2023, 9:36 p.m. UTC | #1
Hi,

Wiktor Żelazny <wz@freeshell.de> skribis:

> * gnu/packages/textutils.scm (python-panflute): New variable.

[...]

> * gnu/packages/textutils.scm (pandoc-include): New variable.

Finally applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index aeff4593a8..fad790c065 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages textutils)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages golang)
@@ -69,6 +70,7 @@  (define-module (gnu packages textutils)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
@@ -1522,3 +1524,30 @@  (define-public ack
 easily specify file types, match highlighting, Perl-Compatible Regular
 Expressions, and being faster to type than grep.")
     (license license:artistic2.0)))
+
+(define-public python-panflute
+  (package
+    (name "python-panflute")
+    (version "2.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "panflute" version))
+              (sha256
+               (base32
+                "1jk5b2sp1h4drkjrg2ks77d0ca6j043n2myvacm77nfc93y9vzff"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-click python-pyyaml))
+    (native-inputs (list python-configparser
+                         python-coverage
+                         python-flake8
+                         python-pandocfilters
+                         python-pytest
+                         python-pytest-cov
+                         python-requests))
+    (home-page "http://scorreia.com/software/panflute/")
+    (synopsis "Pythonic Pandoc filters")
+    (description
+     "Panflute is a Python package that makes Pandoc filters fun to
+write.  It is a pythonic alternative to John MacFarlane's pandocfilters, from
+which it is heavily inspired.")
+    (license license:bsd-3)))