diff mbox series

[bug#61727,6/6] gnu: Add rust-aes-ctr.

Message ID 20230223084241.3762-6-steve@futurile.net
State New
Headers show
Series [bug#61727,1/6] gnu: Update rust-base64. | expand

Commit Message

Steve George Feb. 23, 2023, 8:42 a.m. UTC
* gnu/packages/crates-io.scm (rust-aes-ctr): New variable.

---

 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a18247c65f..310cec113f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1923,6 +1923,35 @@  (define-public rust-aes-0.3
         ("rust-aesni" ,rust-aesni-0.6)
         ("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6))))))
 
+(define-public rust-aes-ctr-0.6
+    (package
+      (name "rust-aes-ctr")
+      (version "0.6.0")
+      (source
+          (origin
+            (method url-fetch)
+            (uri (crate-uri "aes-ctr" version))
+            (file-name (string-append name "-" version ".tar.gz"))
+            (sha256
+              (base32 "0qspjxzrclnb83501595y01dhc0km1ssrbjnwlxhcrsdwp6w6abp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #f
+       #:cargo-inputs
+       (("rust-aesni" ,rust-aesni-0.10)
+        ("rust-aes-soft" ,rust-aes-soft-0.6)
+        ("rust-cipher" ,rust-cipher-0.2)
+        ("rust-ctr", rust-ctr-0.6))
+       #:cargo-development-inputs
+       (("rust-cipher" ,rust-cipher-0.2))))
+      (home-page
+        "https://github.com/RustCrypto/block-ciphers/tree/master/aes")
+      (synopsis "Pure Rust implementation of AES")
+      (description "A pure Rust implementation of the Advanced Encryption
+Standard (AES).  Use the aes crate if possible, as the aes-ctr has been
+deprecated.")
+      (license (list license:expat license:asl2.0))))
+
 (define-public rust-aes-gcm-0.8
   (package
     (name "rust-aes-gcm")