diff mbox series

[bug#61727,1/6] gnu: Update rust-base64.

Message ID 20230223084241.3762-1-steve@futurile.net
State New
Headers show
Series [bug#61727,1/6] gnu: Update rust-base64. | expand

Commit Message

Steve George Feb. 23, 2023, 8:42 a.m. UTC
* gnu/packages/crates-io.scm (rust-base64): Update to 0.13.1

---
Tested update on rust-sequoia-autocrypt, sniffglue, rust-bson and
rust-cookie.

 gnu/packages/crates-io.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Efraim Flashner March 13, 2023, 1:01 p.m. UTC | #1
Thanks for the patches. The first one was already taken care of in the
rust-team branch (which I hope to merge soon). The others I had to make
a few changes on. On some of them the cargo-inputs weren't correct, or
were split between cargo-inputs and cargo-development-inputs. I fixed
them up and pushed the patches.

Thanks! I've pushed them to the rust-team branch.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e615a51b01..aa1fc169c4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5610,7 +5610,7 @@  (define-public rust-base58-0.1
 (define-public rust-base64-0.13
   (package
     (name "rust-base64")
-    (version "0.13.0")
+    (version "0.13.1")
     (source
      (origin
        (method url-fetch)
@@ -5618,7 +5618,7 @@  (define-public rust-base64-0.13
        (file-name
         (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1z82g23mbzjgijkpcrilc7nljpxpvpf7zxf6iyiapkgka2ngwkch"))))
+        (base32 "1s494mqmzjb766fy1kqlccgfg2sdcjb6hzbvzqv2jw65fdi5h6wy"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t