diff mbox series

[bug#61576,21/21] gnu: spice-gtk: Adjust the default file name of the ACL helper binary.

Message ID 20230217170103.10147-22-maxim.cournoyer@gmail.com
State New
Headers show
Series Allow USB redirection as an unprivileged user in in GNOME Boxes | expand

Commit Message

Maxim Cournoyer Feb. 17, 2023, 5:01 p.m. UTC
* gnu/packages/spice.scm (spice-gtk)
[arguments]: Add adjust-default-acl-helper-path phase.

---

 gnu/packages/spice.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 62d1d50e5b..8d2bed38b2 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -159,6 +159,16 @@  (define-public spice-gtk
                 ((".*'session.c',.*") "")
                 (("tests_sources \\+= 'cd-emu.c'" all)
                  (string-append "# " all)))))
+          (add-after 'unpack 'adjust-default-acl-helper-path
+            (lambda _
+              ;; The USB ACL helper used to allow USB redirection as a
+              ;; non-privileged user needs to be setuid, as configured by the
+              ;; gnome-desktop-service-type.  A user can still change the
+              ;; location by specifying the SPICE_USB_ACL_BINARY environment
+              ;; variable.
+              (substitute* "src/usb-acl-helper.c"
+                (("ACL_HELPER_PATH\"/spice-client-glib-usb-acl-helper\"")
+                 "\"/run/setuid-programs/spice-client-glib-usb-acl-helper\""))))
           (add-before 'configure 'correct-polkit-dir
             (lambda _
               (substitute* "meson.build"