diff mbox series

[bug#61565,5/5] gnu: Add rust-mockall.

Message ID 20230216225742.106916-5-steve@futurile.net
State New
Headers show
Series [bug#61562,1/5] gnu: Add rust-pretty-assertions-0.5. | expand

Commit Message

Steve George Feb. 16, 2023, 10:57 p.m. UTC
* gnu/packages/crates-io.scm (rust-mockall-0.11): New variable.

---

 gnu/packages/crates-io.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Steve George Feb. 16, 2023, 11:18 p.m. UTC | #1
Correct series in #61561.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9ce18ea1f0..cb19edaf83 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33760,6 +33760,42 @@  (define-public rust-mockall-double-0.3
 select the mock struct at compile time.  Used with the Mockall crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-mockall-0.11
+  (package
+    (name "rust-mockall")
+    (version "0.11.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "mockall" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0k3g3xxf195vsnzmwza047dv89zlg6h5yj5774wjlndgpdvf8han"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-downcast" ,rust-downcast-0.11)
+        ("rust-fragile" ,rust-fragile-1)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-mockall-derive" ,rust-mockall-derive-0.11)
+        ("rust-predicates" ,rust-predicates-2)
+        ("rust-predicates-tree" ,rust-predicates-tree-1))
+       #:cargo-development-inputs
+       (("rust-async-trait" ,rust-async-trait-0.1)
+        ("rust-futures" ,rust-futures-0.3)
+        ("rust-mockall-double" ,rust-mockall-double-0.3)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-tracing" ,rust-tracing-0.1))))
+    (home-page "https://github.com/asomers/mockall")
+    (synopsis "Powerful mock object library for Rust")
+    (description "Mockall is a rich mocking library with a terse and ergonomic
+interface.  It is written in 100% safe and stable Rust.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-mockall-derive-0.11
   (package
     (name "rust-mockall-derive")