diff mbox series

[bug#61562,4/5] gnu: Add rust-mockall-derive.

Message ID 20230216225742.106916-4-steve@futurile.net
State New
Headers show
Series [bug#61562,1/5] gnu: Add rust-pretty-assertions-0.5. | expand

Commit Message

Steve George Feb. 16, 2023, 10:57 p.m. UTC
* gnu/packages/crates-io.scm (rust-mockall-derive-0.11): New variable.

---
* version 0.11.1 to match rust-mockall version

 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 42137b6853..9ce18ea1f0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33760,6 +33760,32 @@  (define-public rust-mockall-double-0.3
 select the mock struct at compile time.  Used with the Mockall crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-mockall-derive-0.11
+  (package
+    (name "rust-mockall-derive")
+    (version "0.11.1") ; match with the rust-mockall version
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "mockall-derive" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1ixhmsrg5ky4b2jlvbxhlpr3mbv7frd6wr8msm005vijb5rmcb96"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #f
+       #:cargo-inputs 
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))
+       #:cargo-development-inputs 
+       (("rust-pretty-assertions" ,rust-pretty-assertions-0.7))))
+    (home-page "https://github.com/asomers/mockall")
+    (synopsis "Procedural macros for the Mockall crate")
+    (description "Procedural macros for the Mockall crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-model-0.1
   (package
     (name "rust-model")