diff mbox series

[bug#60238,v2,7/7] gnu: Add fava.

Message ID 20230202165816.16772-7-i@dan.games
State New
Headers show
Series gnu: Add fava. | expand

Commit Message

dan Feb. 2, 2023, 4:58 p.m. UTC
* gnu/packages/finance.scm (fava): New variable.
---
 gnu/packages/finance.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c9c8e9b823..c5055f28c4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2022 Collin J. Doering <collin@rekahsoft.ca>
 ;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
 ;;; Copyright © 2023 Frank Pursel <frank.pursel@gmail.com>
+;;; Copyright © 2023 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1942,6 +1943,41 @@  (define-public beancount
 generate a variety of reports from them, and provides a web interface.")
     (license license:gpl2)))
 
+(define-public fava
+  (package
+    (name "fava")
+    (version "1.23.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "fava" version))
+              (sha256
+               (base32
+                "0dbg29i3pdbv8m2n7qspafn5ja1glxf27xcdz8rdn3myjqh183sk"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list beancount
+                             python-babel
+                             python-beautifulsoup4
+                             python-bottle
+                             python-cheroot
+                             python-click
+                             python-flask
+                             python-flask-babel
+                             python-jinja2
+                             python-magic
+                             python-markdown2
+                             python-ply
+                             python-simplejson
+                             python-werkzeug))
+    (native-inputs (list python-pytest
+                         python-chardet
+                         python-dateutil
+                         python-setuptools-scm))
+    (home-page "https://beancount.github.io/fava/")
+    (synopsis "Web interface for the accounting tool Beancount")
+    (description "Fava is a web interface for the double-entry bookkeeping
+software Beancount with a focus on features and usability.")
+    (license license:expat)))
+
 (define-public emacs-beancount
   ;; Note that upstream has not made any release since this project moved
   ;; into its own repository (it was originally part of beancount itself)