diff mbox series

[bug#60238,v2,3/7] gnu: Add python-inflect.

Message ID 20230202165816.16772-3-i@dan.games
State New
Headers show
Series gnu: Add fava. | expand

Commit Message

dan Feb. 2, 2023, 4:58 p.m. UTC
* gnu/packages/python-xyz.scm (python-inflect): New variable.
---
 gnu/packages/python-xyz.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e291a1996..c89fa1c412 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8944,7 +8944,30 @@  (define-public python-portend
     (native-inputs (list python-pytest))
     (home-page "https://github.com/jaraco/portend")
     (synopsis "TCP port monitoring and discovery utilities")
-    (description "Use portend to monitor TCP ports for bound or unbound states.")
+    (description
+     "Use portend to monitor TCP ports for bound or unbound states.")
+    (license license:expat)))
+
+(define-public python-inflect
+  (package
+    (name "python-inflect")
+    (version "6.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "inflect" version))
+              (sha256
+               (base32
+                "16ihdnwck79db21g2pnqq8acc4n68k8agqgx36bghijh22qbr9pi"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-pydantic))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/jaraco/inflect")
+    (synopsis
+     "Correctly generate plurals, singular nouns, ordinals, indefinite articles")
+    (description
+     "inflect.py provide plural inflections, singular noun inflections,
+\"a\"/\"an\" selection for English words, and manipulation of numbers as
+words.")
     (license license:expat)))
 
 (define-public python-simplegeneric