diff mbox series

[bug#60238,v2,4/7] gnu: Add python-jaraco-text.

Message ID 20230202165816.16772-4-i@dan.games
State New
Headers show
Series [bug#60238,v2,1/7] gnu: Add python-markdown2. | expand

Commit Message

dan Feb. 2, 2023, 4:58 p.m. UTC
* gnu/packages/python-xyz.scm (python-jaraco-text): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c89fa1c412..2b12b3392d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8970,6 +8970,34 @@  (define-public python-inflect
 words.")
     (license license:expat)))
 
+(define-public python-jaraco-text
+  (package
+    (name "python-jaraco-text")
+    (version "3.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jaraco.text" version))
+              (sha256
+               (base32
+                "0lc3ji0xgd35rbrr2yrp3ykhmgp2xjj1r04w2yl6w5zyjnaminqd"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-autocommand
+                             python-importlib-resources
+                             python-inflect
+                             python-jaraco-context
+                             python-jaraco-functools
+                             python-more-itertools))
+    (native-inputs (list python-pathlib2
+                         python-pytest))
+    (home-page "https://github.com/jaraco/jaraco.text")
+    (synopsis "Module for text manipulation")
+    (description
+     "This package provides handy routines for dealing with text,
+such as wrapping, substitution, trimming, stripping, prefix and suffix
+removal, line continuation, indentation, comment processing, identifier
+processing, values parsing, case insensitive comparison, and more.")
+    (license license:expat)))
+
 (define-public python-simplegeneric
   (package
     (name "python-simplegeneric")