diff mbox series

[bug#60238,v2,1/7] gnu: Add python-markdown2.

Message ID 20230202165816.16772-1-i@dan.games
State New
Headers show
Series [bug#60238,v2,1/7] gnu: Add python-markdown2. | expand

Commit Message

dan Feb. 2, 2023, 4:58 p.m. UTC
* gnu/packages/python-xyz.scm (python-markdown2): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b14c4ff0f3..bcf1d29727 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -132,6 +132,7 @@ 
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11562,6 +11563,23 @@  (define-public python-markdown
 markdown_py is also provided to convert Markdown files to HTML.")
     (license license:bsd-3)))
 
+(define-public python-markdown2
+  (package
+    (name "python-markdown2")
+    (version "2.4.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "markdown2" version))
+              (sha256
+               (base32
+                "1c1bqkggr50274gs478cnzm8bljqifdnbg20zla1nn8n3sz4snzn"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/trentm/python-markdown2")
+    (synopsis "Fast and complete Python implementation of Markdown")
+    (description
+     "This package provides a fast and complete Python implementation of Markdown.")
+    (license license:expat)))
+
 (define-public python-mdx-include
   (package
     (name "python-mdx-include")