diff mbox series

[bug#61224] gnu: Add r-streamgraph.

Message ID 20230202101504.22751-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61224] gnu: Add r-streamgraph. | expand

Commit Message

nafkhamdc Feb. 2, 2023, 10:15 a.m. UTC
* gnu/packages/bioinformatics.scm (r-streamgraph): New variable.
---
 gnu/packages/bioinformatics.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ricardo Wurmus Feb. 2, 2023, 11:24 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8c75607a65..714db27c16 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -690,6 +690,39 @@  (define-public r-rhtslib12
 developers of other R packages who wish to make use of HTSlib.")
       (license license:lgpl2.0+))))
 
+(define-public r-streamgraph
+  (let ((commit "76f7173ec89d456ace5943a512e20b1f6810bbcb")
+        (revision "1"))
+    (package
+      (name "r-streamgraph")
+      (version (git-version "0.9.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/hrbrmstr/streamgraph")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "010rhnby5a9dg08jvlkr65b3p9iipdxi2f5m1k6j53s80p25yvig"))))
+      (properties `((upstream-name . "streamgraph")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-dplyr
+                               r-htmltools
+                               r-htmlwidgets
+                               r-magrittr
+                               r-tidyr
+                               r-xts))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/hrbrmstr/streamgraph")
+      (synopsis "This is an htmlwidget for building streamgraph visualizations")
+      (description
+       "A streamgraph is a type of stacked area chart.
+It represents the evolution of a numeric variable for several groups.
+Areas are usually displayed around a central axis, and edges are rounded
+to give a flowing shape.")
+      (license license:expat))))
+
 (define-public pbbam
   (package
     (name "pbbam")