diff mbox series

[bug#60997,1/4] gnu: Add python-cmseq.

Message ID 20230122004951.119277-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#60997,1/4] gnu: Add python-cmseq. | expand

Commit Message

Mădălin Ionel Patrașcu Jan. 22, 2023, 12:49 a.m. UTC
* gnu/packages/bioinformatics.scm (python-cmseq): New variable.
---
 gnu/packages/bioinformatics.scm | 29 ++++++++++++++++++++++++++++-
 1 file changed, 28 insertions(+), 1 deletion(-)


base-commit: f088763356e88c4911ee933fdafcad6ed66a7aa3

Comments

Ricardo Wurmus Jan. 24, 2023, 8:36 a.m. UTC | #1
Hi Mădălin,

> * gnu/packages/bioinformatics.scm (python-cmseq): New variable.

Thanks for the patch.

Unfortunately, this is incomplete:

- The tool calls out to samtools (see cmseq/cmseq.py), so it needs
  samtools as an input and the call needs to be patched.

- The README says that biopython <= 1.76 is needed for polymut.py.
  You’re using 1.80.

> +    (build-system python-build-system)

Please consider using the pyproject-build-system.

> +    (arguments
> +     (list #:tests? #f )) ;pypi no tests

Apparantly, there are no tests anywhere.  It’s not a pypi problem.
Please update the comment and remove that extra space after #f.

> +    (home-page "http://github.com/SegataLab/cmseq/")

Please use HTTPS.  “guix lint” informs you about the redirect.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 36c9db90bd..4e7bc07a5f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2017, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018, 2019, 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
@@ -1014,6 +1014,33 @@  (define-public python-cellbender
 from high-throughput single-cell RNA sequencing (scRNA-seq) data.")
     (license license:bsd-3)))
 
+(define-public python-cmseq
+  (package
+    (name "python-cmseq")
+    (version "1.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "CMSeq" version))
+              (sha256
+               (base32
+                "0p6a99c299m5wi2z57dgqz52m1z3nfr8mv7kdnk2jvl2p9nql0wk"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f )) ;pypi no tests
+    (propagated-inputs
+     (list python-bcbio-gff
+           python-biopython
+           python-numpy
+           python-pandas
+           python-pysam
+           python-scipy))
+    (home-page "http://github.com/SegataLab/cmseq/")
+    (synopsis "Set of utilities on sequences and BAM files")
+    (description
+     "CMSeq is a set of commands to provide an interface to .bam files for coverage
+and sequence consensus.")
+    (license license:expat)))
+
 (define-public python-htsget
   (package
    (name "python-htsget")