diff mbox series

[bug#60878,2/2] gnu: Add r-anvil.

Message ID 20230117131823.55318-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#60878,1/2] gnu: Add r-rapiclient. | expand

Commit Message

Mădălin Ionel Patrașcu Jan. 17, 2023, 1:18 p.m. UTC
* gnu/packages/bioconductor.scm (r-anvil): New variable.
---
 gnu/packages/bioconductor.scm | 41 +++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ca236bcf75..35aed4b62c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2443,6 +2443,47 @@  (define-public r-animalcules
 to understand their data better and discover new insights.")
     (license license:artistic2.0)))
 
+(define-public r-anvil
+  (package
+    (name "r-anvil")
+    (version "1.10.1")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "AnVIL" version))
+              (sha256
+               (base32
+                "0iqsffkrxv28g9cddx2w05f2dbscwxhh6bpizwa8xaxhvn5bcpsv"))))
+    (properties `((upstream-name . "AnVIL")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocmanager
+           r-dplyr
+           r-dt
+           r-futile-logger
+           r-htmltools
+           r-httr
+           r-jsonlite
+           r-miniui
+           r-rapiclient
+           r-rlang
+           r-shiny
+           r-tibble
+           r-tidyr
+           r-tidyselect))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/AnVIL")
+    (synopsis "Provides access to AnVIL, Terra, Leonardo and other projects")
+    (description
+     "The AnVIL is a cloud computing resource developed in part by the National
+Human Genome Research Institute.  The AnVIL package provides end-user and developer
+functionality.  For the end-user, AnVIL provides fast binary package installation,
+utitlities for working with Terra/AnVIL table and data resources, and convenient
+functions for file movement to and from Google cloud storage.  For developers,
+AnVIL provides programatic access to the Terra, Leonardo, Rawls, Dockstore, and
+Gen3 RESTful programming interface, including helper functions to transform JSON
+responses to formats more amenable to manipulation in R.")
+    (license license:artistic2.0)))
+
 (define-public r-aldex2
   (package
     (name "r-aldex2")