diff mbox series

[bug#60877,2/4] gnu: Add r-missforest.

Message ID 20230117122538.41537-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#60877,1/4] gnu: Add r-baseline. | expand

Commit Message

Mădălin Ionel Patrașcu Jan. 17, 2023, 12:25 p.m. UTC
* gnu/packages/cran.scm (r-missforest): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 53f3ebbcf5..6ae5b96eb2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15227,6 +15227,36 @@  (define-public r-misc3d
     ;; Any version of the GPL.
     (license (list license:gpl2+ license:gpl3+))))
 
+(define-public r-missforest
+  (package
+    (name "r-missforest")
+    (version "1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "missForest" version))
+              (sha256
+               (base32
+                "13c38hpl60ca1kwyv61cxsla6ccmsj4qzp0vrxcq7b827fh5aw21"))))
+    (properties `((upstream-name . "missForest")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-dorng
+           r-foreach
+           r-iterators
+           r-itertools
+           r-randomforest))
+    (home-page "https://github.com/stekhoven/missForest")
+    (synopsis "Nonparametric missing value imputation using Random Forest")
+    (description
+     "The function @code{missForest} in this package is used to impute missing
+values, particularly in the case of mixed-type data.  It uses a random forest
+trained on the observed values of a data matrix to predict the missing values.
+It can be used to impute continuous and/or categorical data, including complex
+interactions and non-linear relations.  It yields an @acronym{OOB, out-of-bag}
+imputation error estimate without the need of a test set or elaborate cross-
+validation.  It can be run in parallel to save computation time.")
+    (license license:gpl2+)))
+
 (define-public r-ks
   (package
     (name "r-ks")