diff mbox series

[bug#60877,1/4] gnu: Add r-baseline.

Message ID 20230117122538.41537-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#60877,1/4] gnu: Add r-baseline. | expand

Commit Message

Mădălin Ionel Patrașcu Jan. 17, 2023, 12:25 p.m. UTC
* gnu/packages/cran.scm (r-baseline): New variable.
---
 gnu/packages/cran.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)


base-commit: 789d73234d5b6bbd83bb054146d5bbd1d374d51a

Comments

Ricardo Wurmus Jan. 22, 2023, 8:09 a.m. UTC | #1
Hi Mădălin,

> * gnu/packages/cran.scm (r-baseline): New variable.

Thanks for the patches.

The r-baseline package actually needs an additional input for the GUI.
I packaged gWidgets2tcltk and added it as an input.  (The GTK variant
has been archived on CRAN because RGtk has been abandoned.)

I fixed a typo in a description and pushed.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3fcbd3b9f6..53f3ebbcf5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
 ;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
 ;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2018, 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2020-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
@@ -9241,6 +9241,31 @@  (define-public r-base64url
 systems.")
     (license license:gpl3)))
 
+(define-public r-baseline
+  (package
+    (name "r-baseline")
+    (version "1.3-4")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "baseline" version))
+              (sha256
+               (base32
+                "1kl68zvyi2zd73jy3axrvrymwn4y6l4pd62nz0fciwbgkjhz3yyx"))))
+    (properties `((upstream-name . "baseline")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-limsolve r-sparsem))
+    (home-page "https://github.com/khliland/baseline/")
+    (synopsis "Baseline correction of spectra")
+    (description
+     "This package is a collection of baseline correction algorithms.  Beside
+those it provides a framework and a Tcl/Tk enabled GUI for optimizing baseline
+algorithm parameters.  Typical use is the removal of the background effects from
+spectra, which are originating from various types of spectroscopy and spectrometry.
+Also, there is a possibility of optimizing this with regard to regression or
+classification results.  Correction methods include polynomial fitting, weighted
+local smoothers and many more.")
+    (license license:gpl2)))
+
 (define-public r-radiant-data
   (package
     (name "r-radiant-data")