diff mbox series

[bug#60224,v5,04/13] gnu: make-uboot-package: Simplify build.

Message ID 20230116032544.1378-4-maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#60224,v5,01/13] gnu: make-u-boot-package: Add a u-boot argument and use gexps. | expand

Commit Message

Maxim Cournoyer Jan. 16, 2023, 3:25 a.m. UTC
* gnu/packages/bootloaders.scm (make-u-boot-package) <same-arch?>: Rename
procedure to 'native-build?'.
[native-inputs]: Remove field.
[arguments]: Specify the #:target argument, when not natively building.
Adjust for the above renaming.

---

Changes in v5:
- Remove bogus comment

Changes in v3:
- Rename %current-target-system to %current-system in comment

 gnu/packages/bootloaders.scm | 19 +++++++------------
 1 file changed, 7 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 7ec26dda05..b7a31c8b48 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -863,9 +863,9 @@  (define*-public (make-u-boot-package board triplet
 NAME-SUFFIX is appended to the package name, while APPEND-DESCRIPTION is
 appended to the package description.  U-BOOT can be used when a fork or a
 different version of U-Boot must be used."
-  (let ((same-arch? (lambda ()
-                      (string=? (%current-system)
-                                (gnu-triplet->nix-system triplet)))))
+  (let ((native-build? (lambda ()
+                         (string=? (%current-system)
+                                   (gnu-triplet->nix-system triplet)))))
     (package
       (inherit u-boot)
       (name (string-append "u-boot-"
@@ -876,16 +876,11 @@  (define*-public (make-u-boot-package board triplet
                        (string-append (package-description u-boot)
                                       "\n\n" append-description)
                        (package-description u-boot)))
-      (native-inputs
-       ;; Note: leave the native u-boot inputs first, so that a user can
-       ;; override the cross-gcc and cross-binutils packages.
-       `(,@(package-native-inputs u-boot)
-         ,@(if (not (same-arch?))
-               `(("cross-gcc" ,(cross-gcc triplet))
-                 ("cross-binutils" ,(cross-binutils triplet)))
-               `())))
+      (build-system gnu-build-system)
       (arguments
        (substitute-keyword-arguments (package-arguments u-boot)
+         ((#:target _ #f)
+          (and (not (native-build?)) triplet))
          ((#:modules modules '())
           `((ice-9 ftw)
             (srfi srfi-1)
@@ -902,7 +897,7 @@  (define*-public (make-u-boot-package board triplet
          ((#:make-flags make-flags '())
           #~(list "HOSTCC=gcc"
                   "KBUILD_VERBOSE=1"
-                  #$@(if (not (same-arch?))
+                  #$@(if (not (native-build?))
                          (list (string-append "CROSS_COMPILE=" triplet "-"))
                          '())
                   #$@make-flags))