diff mbox series

[bug#60224,v5,03/13] gnu: u-boot: Reduce the number of native inputs.

Message ID 20230116032544.1378-3-maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#60224,v5,01/13] gnu: make-u-boot-package: Add a u-boot argument and use gexps. | expand

Commit Message

Maxim Cournoyer Jan. 16, 2023, 3:25 a.m. UTC
The extra python inputs are only needed for running the u-boot-test-tools test
suite.  This lowers the requirements for cross-building the various u-boot
packages.

* gnu/packages/bootloaders.scm (u-boot) [native-inputs]: Delete bc.
Move python-coverage, python-pycryptodomex and python-pytest to...
* gnu/packages/bootloaders.scm (u-boot-tools) [native-inputs]: ... here.

---

Changes in v5:
- New commit.

 gnu/packages/bootloaders.scm | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b17f8b1a9f..7ec26dda05 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -662,8 +662,7 @@  (define u-boot
                 "1y5x8vxdgsqdqlsvq01mn8lmw53fqairkhvhhjx83hjva0m4id2h"))))
     (build-system  gnu-build-system)
     (native-inputs
-     (list bc
-           bison
+     (list bison
            dtc
            gnutls
            flex
@@ -672,9 +671,6 @@  (define u-boot
            perl
            pkg-config                   ;for 'make menuconfig'
            python
-           python-coverage
-           python-pycryptodomex
-           python-pytest
            swig
            (list util-linux "lib")))
     (home-page "https://www.denx.de/wiki/U-Boot/")
@@ -725,7 +721,7 @@  (define-public u-boot-tools
     (name "u-boot-tools")
     (native-inputs
      (modify-inputs (package-native-inputs u-boot)
-       (prepend sdl2)))
+       (prepend python-coverage python-pycryptodomex python-pytest sdl2)))
     (arguments
      `(#:make-flags '("HOSTCC=gcc")
        #:test-target "tcheck"