diff mbox series

[bug#60838,4/8] gnu: python-janus: Update to 1.0.0.

Message ID 20230115215221.25274-1-felgru@posteo.net
State New
Headers show
Series Add datasette and python-sqlite-utils. | expand

Commit Message

Felix Gruber Jan. 15, 2023, 9:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-janus): Update to 1.0.0.
[propagated-inputs]: Add python-typing-extensions.
---
 gnu/packages/python-xyz.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1dbe9d611f..e614ffdf2b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -291,13 +291,13 @@  (define-public python-xmldiff
 (define-public python-janus
   (package
     (name "python-janus")
-    (version "0.6.1")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "janus" version))
        (sha256
-        (base32 "030xvl2vghi5ispfalhvch1rl6i2jsy5bf1dgjafa7vifppy04j7"))))
+        (base32 "04hnrdcf03g1s0x3sr72sh9gnszz6kyfsl9dg8a4n0zvvhn6z5yz"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -307,6 +307,8 @@  (define-public python-janus
              (when tests?
                (add-installed-pythonpath inputs outputs)
                (invoke "pytest" "--cov=janus" "--cov=tests")))))))
+    (propagated-inputs
+     (list python-typing-extensions))
     (native-inputs
      (list python-pytest python-pytest-cov python-pytest-asyncio))
     (home-page "https://github.com/aio-libs/janus/")