mbox series

[bug#60838,0/8] Add datasette and python-sqlite-utils.

Message ID 20230115214753.25034-1-felgru@posteo.net
Headers show
Series Add datasette and python-sqlite-utils. | expand

Message

Felix Gruber Jan. 15, 2023, 9:47 p.m. UTC
This patchset adds new packages for the database exploration and
manipulation tools datasette and sqlite-utils, as well as some missing
dependencies of those two packages.

Since datasette and sqlite-utils do not contain any tests in their pypi
source archives, I've tested both on the global power plant database,
which can be downloaded as CSV file from
https://datasets.wri.org/dataset/globalpowerplantdatabase

First, I tested sqlite-utils by converting the power plants CSV file
to a sqlite database, using

  sqlite-utils insert powerplants.db powerplants \
    global_power_plant_database.csv --csv

Then I used datasette to explore the newly created database with

  datasette serve powerplants.db -o

(Note the -o option to automatically open the datasette instance in
your webbrowser.)

So far everything seems to work.

Felix Gruber (8):
  gnu: Add python-click-default-group-wheel.
  gnu: Add python-sqlite-fts4.
  gnu: Add python-sqlite-utils.
  gnu: python-janus: Update to 1.0.0.
  gnu: Add python-pluggy-next.
  gnu: Add python-asgi-lifespan.
  gnu: Add python-asgi-csrf.
  gnu: Add datasette.

 gnu/packages/databases.scm  | 104 ++++++++++++++++++++++++++++++++++++
 gnu/packages/python-web.scm |  50 ++++++++++++++++-
 gnu/packages/python-xyz.scm |  45 ++++++++++++++--
 3 files changed, 195 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer March 22, 2023, 12:59 a.m. UTC | #1
Hi Felix,

Felix Gruber <felgru@posteo.net> writes:

> This patchset adds new packages for the database exploration and
> manipulation tools datasette and sqlite-utils, as well as some missing
> dependencies of those two packages.
>
> Since datasette and sqlite-utils do not contain any tests in their pypi
> source archives [...]

This happens frequently for the PyPI source archives; I'd recommend
switching to git as automated tests are really worth to preserve the
package longer term.  Could you look into enabling the test suite by
checking out the projects source from git?  The pyproject-build-system
would probably make your life easy then (it knows to run pytest if it's
in the native-inputs, for example).