diff mbox series

[bug#60673,31/39] gnu: Add ocaml-async.

Message ID 20230109003529.23375-31-raingloom@riseup.net
State New
Headers show
Series [bug#60673,01/39] gnu: Add ocaml-domain-name. | expand

Commit Message

Csepp Jan. 9, 2023, 12:35 a.m. UTC
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-async): New variable.
---
 gnu/packages/ocaml.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d2c41a2fdf..c94beb408c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8457,6 +8457,38 @@  (define-public ocaml-async-rpc-kernel
 JavaScript.")
     (license license:expat)))
 
+(define-public ocaml-async
+  (package
+    (name "ocaml-async")
+    (version "0.15.0")
+    (source (origin
+              (method url-fetch)
+              (uri
+               "https://ocaml.janestreet.com/ocaml-core/v0.15/files/async-v0.15.0.tar.gz")
+              (sha256
+               (base32
+                "1afnls0m4izzp933h606k0vj43krfsy4ypnybsidq7pd9cfb4fqd"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-async-kernel
+                             ocaml-async-rpc-kernel
+                             ocaml-async-unix
+                             ocaml-core
+                             ocaml-core-kernel
+                             ocaml-core-unix
+                             ocaml-ppx-jane
+                             ocaml-ppx-log
+                             ocaml-textutils))
+    ;; TODO one test dependency is deprecated, the other is nowhere to be found
+    (arguments '(#:tests? #f))
+    ;; (native-inputs (list ocaml-netkit-sockets ocaml-qtest-deprecated))
+    (home-page "https://github.com/janestreet/async")
+    (synopsis "Asynchronous execution library")
+    (description
+     "Library for asynchronous programming, i.e., programming where some part
+of the program must wait for things that happen at times determined by some
+external entity (like a human or another program).")
+    (license license:expat)))
+
 (define-public ocaml-textutils-kernel
   (package
     (name "ocaml-textutils-kernel")