diff mbox series

[bug#60673,17/39] gnu: Add ocaml-mirage-profile.

Message ID 20230109003529.23375-17-raingloom@riseup.net
State New
Headers show
Series [bug#60673,01/39] gnu: Add ocaml-domain-name. | expand

Commit Message

Csepp Jan. 9, 2023, 12:35 a.m. UTC
From: raingloom <raingloom@riseup.net>

* gnu/packages/ocaml.scm (ocaml-mirage-profile): New variable.
---
 gnu/packages/ocaml.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 62fb00dd37..33bc997dc5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3890,6 +3890,20 @@  (define-public ocaml-mirage-profile-unix
 non-profiling case.")
     (license license:bsd-2)))
 
+(define-public ocaml-mirage-profile
+  (package
+    (inherit ocaml-mirage-profile-unix)
+    (name "ocaml-mirage-profile")
+    (arguments '(#:package "mirage-profile"
+                 ;; TODO cyclic dependency with mirage-profile
+                 ;; It could be broken using package variants, if not for
+                 ;; propagated inputs leading to version conflicts.
+                 #:tests? #f))
+    (propagated-inputs
+     (modify-inputs
+         (package-propagated-inputs ocaml-mirage-profile-unix)
+       (append ocaml-mirage-profile-unix)))))
+
 (define-public ocaml-ocurl
   (package
     (name "ocaml-ocurl")