diff mbox series

[bug#53019,PATCHv2,3/4] gnu: Add python-ddlparse.

Message ID 20230104160855.6241-3-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,PATCHv2,1/4] gnu: Add python-coverage-5.5 | expand

Commit Message

Giacomo Leidi Jan. 4, 2023, 4:08 p.m. UTC
* gnu/packages/python-xyz.scm (python-ddlparse): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0b54443af..dae72728a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3897,6 +3897,36 @@  (define-public python-jsondiff
 compare, diff, and patch JSON and JSON-like structures in Python.")
    (license license:expat)))
 
+(define-public python-ddlparse
+  (package
+    (name "python-ddlparse")
+    (version "1.10.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "ddlparse" version))
+        (sha256
+          (base32 "1nh8m6rxslwk05daxshxmgk41qfp18yynydba49b13l4m8dnh634"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest")))))))
+    (native-inputs
+     (list python-codecov
+           python-coveralls
+           python-pytest
+           python-pytest-cov
+           python-tox))
+    (propagated-inputs (list python-pyparsing))
+    (home-page "https://github.com/shinichi-takii/ddlparse")
+    (synopsis "Parses and converts DDL to BigQuery JSON schema")
+    (description "This package provides @{ddlparse}, a Python library to parse
+and convert DDL to BigQuery JSON schema.")
+    (license license:bsd-3)))
+
 (define-public python-jsonschema
   (package
     (name "python-jsonschema")