diff mbox series

[bug#53019,PATCHv2,1/4] gnu: Add python-coverage-5.5

Message ID 20230104160855.6241-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,PATCHv2,1/4] gnu: Add python-coverage-5.5 | expand

Commit Message

Giacomo Leidi Jan. 4, 2023, 4:08 p.m. UTC
This has been also sent to staging in https://issues.guix.gnu.org/58421.

* gnu/packages/check.scm (python-coverage-5.5): New variable.
---
 gnu/packages/check.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)


base-commit: ddebb5c5634fcfbec9571453f2db72b238d73e75
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index aaa41777dc..d042f60207 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -41,6 +41,7 @@ 
 ;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
 ;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2017,6 +2018,19 @@  (define-public python-coverage
 executed.")
     (license license:bsd-3)))
 
+;; TODO: This can be removed after staging is merged.
+(define-public python-coverage-5.5
+  (package
+    (inherit python-coverage)
+    (version "5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "coverage" version))
+       (sha256
+        (base32
+         "0b112ly7vvplvm9l411aqknxhr7fzfyp28xhflhkcx78l3lqzrzb"))))))
+
 (define-public python-pytest-asyncio
   (package
     (name "python-pytest-asyncio")