diff mbox series

[bug#60180,1/3] gnu: ola: Update to 0.10.8.

Message ID 20221218184656.24432-1-simon@simonsouth.net
State New
Headers show
Series gnu: ola: Update to 0.10.8, fixing build. | expand

Commit Message

Simon South Dec. 18, 2022, 6:46 p.m. UTC
* gnu/packages/lighting.scm (ola): Update to 0.10.8.
---
 gnu/packages/lighting.scm | 82 +++++++++++++++++++--------------------
 1 file changed, 39 insertions(+), 43 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index 5850da84d8..5af49eea86 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -36,52 +36,48 @@  (define-module (gnu packages lighting)
   #:use-module (gnu packages protobuf))
 
 (define-public ola
-  ;; Use a commit that allows building with libmicrohttpd 0.9.71.
-  ;; https://github.com/OpenLightingProject/ola/pull/1651
-  (let ((commit "5d882936436240b312b3836afd199587beaca840")
-        (revision "0"))
-    (package
-      (name "ola")
-      (version (git-version "0.10.7" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/OpenLightingProject/ola")
-               (commit commit)))
-         (sha256
-          (base32 "1bhl3gvmvmnyrygfj13cibf2xirm285m8abjkaxq22hrqbsvab2m"))
-         (file-name (git-file-name name version))))
-      (build-system gnu-build-system)
-      (native-inputs
-       (list bison
-             cppunit
-             flex
-             pkg-config
-             ;; For git repository bootstrapping.
-             autoconf
-             automake
-             libtool))
-      (inputs
-       `(("libftdi" ,libftdi)
-         ("libmicrohttpd" ,libmicrohttpd)
-         ("libusb" ,libusb)
-         ("libuuid" ,util-linux "lib")
-         ("zlib" ,zlib)))
-      (propagated-inputs
-       (list protobuf))       ; for pkg-config --libs libola
-      (arguments
-       `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
-         ;; build to fail on low memory systems.  We disable that with the
-         ;; following configure flags.
-         #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
-      (synopsis "Framework for controlling entertainment lighting equipment")
-      (description "The Open Lighting Architecture is a framework for lighting
+  (package
+    (name "ola")
+    (version "0.10.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OpenLightingProject/ola")
+             (commit version)))
+       (sha256
+        (base32 "17dwmjdw87hv314gv5b1rmh5jglz8a0rzw7wj26xn74xw2jvxa6l"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list bison
+           cppunit
+           flex
+           pkg-config
+           ;; For git repository bootstrapping.
+           autoconf
+           automake
+           libtool))
+    (inputs
+     `(("libftdi" ,libftdi)
+       ("libmicrohttpd" ,libmicrohttpd)
+       ("libusb" ,libusb)
+       ("libuuid" ,util-linux "lib")
+       ("zlib" ,zlib)))
+    (propagated-inputs
+     (list protobuf))       ; for pkg-config --libs libola
+    (arguments
+     `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
+       ;; build to fail on low memory systems.  We disable that with the
+       ;; following configure flags.
+       #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
+    (synopsis "Framework for controlling entertainment lighting equipment")
+    (description "The Open Lighting Architecture is a framework for lighting
 control information.  It supports a range of protocols and over a dozen USB
 devices.  It can run as a standalone service, which is useful for converting
 signals between protocols, or alternatively using the OLA API, it can be used
 as the backend for lighting control software.  OLA runs on many different
 platforms including ARM, which makes it a perfect fit for low cost Ethernet to
 DMX gateways.")
-      (home-page "https://www.openlighting.org/ola")
-      (license license:lgpl2.1+))))
+    (home-page "https://www.openlighting.org/ola")
+    (license license:lgpl2.1+)))