diff mbox series

[bug#58437,3/3,v3] gnu: trezor-agent: Fix build by adding native-inputs.

Message ID 20221206184607.8128-3-attila@lendvai.name
State New
Headers show
Series [bug#58437,1/3,v3] gnu: python-trezor: Update to 0.13.3. | expand

Commit Message

Attila Lendvai Dec. 6, 2022, 6:46 p.m. UTC
The tests, and thus the build, were failing prior to this change.
---
 gnu/packages/finance.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index a81d82ad60..ed4374c2fd 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1235,8 +1235,10 @@  (define-public trezor-agent
     (build-system python-build-system)
     (inputs
      (list python-trezor python-trezor-agent))
-    (native-inputs
-     (list python-attrs))
+    (native-inputs ; Only needed for running the tests
+     (list python-attrs
+           python-bech32
+           python-simple-rlp))
     (home-page "https://github.com/romanz/trezor-agent")
     (synopsis "Using Trezor as hardware SSH/GPG agent")
     (description "This package allows using Trezor as a hardware SSH/GPG