diff mbox series

[bug#58437,2/3,v3] gnu: python-trezor-agent: Update to 0.14.5.

Message ID 20221206184607.8128-2-attila@lendvai.name
State New
Headers show
Series [bug#58437,1/3,v3] gnu: python-trezor: Update to 0.13.3. | expand

Commit Message

Attila Lendvai Dec. 6, 2022, 6:46 p.m. UTC
---
 gnu/packages/finance.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 287ee38041..a81d82ad60 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -911,7 +911,7 @@  (define-public python-trezor-agent
   ;; the toplevel app called trezor-agent.
   (package
     (name "python-trezor-agent")
-    (version "0.14.4")
+    (version "0.14.5")
     (source
      (origin
        (method git-fetch)
@@ -920,7 +920,7 @@  (define-public python-trezor-agent
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
+        (base32 "1syg5an5hj8sr56hvcr45y8dymwy8va5h0pfyrmsnxcz8z5q1124"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -948,8 +948,12 @@  (define-public python-trezor-agent
            python-semver
            python-unidecode
            python-wheel))
-    (native-inputs
-     (list gnupg python-mock python-pytest))
+    (native-inputs ; Only needed for running the tests
+     (list gnupg
+           python-bech32
+           python-cryptography
+           python-mock
+           python-pytest))
     (home-page "https://github.com/romanz/trezor-agent")
     (synopsis "Use hardware wallets as SSH and GPG agent")
     (description