diff mbox series

[bug#59840,1/3] gnu: Add r-clustercrit.

Message ID 20221205172726.24426-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59840,1/3] gnu: Add r-clustercrit. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 5, 2022, 5:27 p.m. UTC
* gnu/packages/cran.scm (r-clustercrit): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: b2a848d23d37f31496e1ff664f1dcf6abcdcc388

Comments

Ricardo Wurmus Dec. 12, 2022, 2:52 p.m. UTC | #1
Thanks, I applied this series with minor changes.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..6c2b8c834b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14094,6 +14094,30 @@  (define-public r-npsurv
 exact and interval-censored observations.")
     (license license:gpl2+)))
 
+(define-public r-clustercrit
+  (package
+    (name "r-clustercrit")
+    (version "1.2.8")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "clusterCrit" version))
+              (sha256
+               (base32
+                "10pz1bikdbkm2ky3xnagp0qv60whalavp6j39b4p7d75jj5xcxgk"))))
+    (properties `((upstream-name . "clusterCrit")))
+    (build-system r-build-system)
+    (native-inputs (list gfortran))
+    (home-page "https://www.r-project.org/")
+    (synopsis "Computing clustering validation indices")
+    (description
+     "The @code{clusterCrit} package provides an implementation of the following
+indices: Czekanowski-Dice, Folkes-Mallows, Hubert Γ, Jaccard, McNemar, Kulczynski,
+Phi, Rand, Rogers-Tanimoto, Russel-Rao or Sokal-Sneath.  ClusterCrit defines
+several functions which compute internal quality indices or external comparison
+indices.  The partitions are specified as an integer vector giving the index of
+the cluster each observation belongs to.")
+    (license license:gpl2+)))
+
 (define-public r-clusteval
   (package
     (name "r-clusteval")