diff mbox series

[bug#59560,v2,1/2] gnu: Add emacs-function-args.

Message ID 20221125061426.23015-1-jgart@dismail.de
State New
Headers show
Series [bug#59560,v2,1/2] gnu: Add emacs-function-args. | expand

Commit Message

jgart Nov. 25, 2022, 6:14 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-function-args): New variable.

Hi,

I forgut to include the hash update. Ignore v1 and use this v2 instead.

all best,

jgart
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou Nov. 26, 2022, 10:33 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-function-args): New variable.

Thank you.

> +         (sha256
> +          (base32
> +           "1vxrjy6k030hcbclblgcaaw7h6k17kl3n9zla08527525c0gma01"))
> +         (file-name (git-file-name name version))))

Nitpick: Usuallly the file-name field resides before sha256.

> +      (propagated-inputs (list emacs-ivy))
> +      (build-system emacs-build-system)

Other nitpick in the same vein: propagated-inputs usually come after
build-system field.

> +      (description
> +"GNU Emacs package for showing an inline arguments hint for the C/C++
> +function at point.")

This is not a complete sentence. I would also add that the package
extends C++ mode completion provided by CEDET. What about something
like:

  Function-args shows inline arguments hints exactly where the C/C++
  function call is, rather than in the minibuffer. It also extends C++
  mode completion provided by CEDET.

Could you send an updated patch?

Regards,
Nicolas Goaziou April 4, 2023, 6:59 p.m. UTC | #2
Closing. Patch already applied.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5d6f4d040f..ec1d59931d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11083,6 +11083,32 @@  (define-public emacs-lispyville
 state and will work even without lispy being enabled.")
       (license license:gpl3+))))
 
+(define-public emacs-function-args
+  ;; The latest release is from August 21, 2017.
+  (let ((commit "beba049751fed78666c87bd146a6f1cf149bb819")
+        (revision "0"))
+    (package
+      (name "emacs-function-args")
+      (version (git-version "0.6.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/abo-abo/function-args")
+               (commit commit)))
+         (sha256
+          (base32
+           "1vxrjy6k030hcbclblgcaaw7h6k17kl3n9zla08527525c0gma01"))
+         (file-name (git-file-name name version))))
+      (propagated-inputs (list emacs-ivy))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/abo-abo/function-args")
+      (synopsis "C/C++ completion for GNU Emacs")
+      (description
+"GNU Emacs package for showing an inline arguments hint for the C/C++
+function at point.")
+      (license license:gpl3+))))
+
 (define-public emacs-lpy
   ;; There is no proper release/tag.
   (let ((commit "ce78a4613458790cc785c1687af7eed8f0d8d66c")