diff mbox series

[bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.

Message ID 20221120134802.19051-1-felix.lechner@lease-up.com
State New
Headers show
Series [bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Nov. 20, 2022, 1:47 p.m. UTC
* gnu/packages/golang.scm
  (go-github-com-nathan-osman-go-sunrise): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: ac09fcb955e9358c330d728693759ca1a2e20542

Comments

\( Nov. 20, 2022, 1:53 p.m. UTC | #1
Heya,

Thanks for splitting them! A few remarks:

On Sun Nov 20, 2022 at 1:47 PM GMT, Felix Lechner wrote:
> * gnu/packages/golang.scm
>   (go-github-com-nathan-osman-go-sunrise): New variable.

Indentation for this should look something like:

  * gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
    New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2485,6 +2485,33 @@ (define-public go-gopkg-in-go-playground-validator-v9

> +      (arguments
> +       '(#:import-path "github.com/nathan-osman/go-sunrise"))

Please use

  (list #:import-path ...)

instead.

> +      (synopsis "Calculates the sunrise and sunset times for a given location")

Maybe change this to:

  (synopsis "Calculate sunrise and sunset times in Go")

> +      (description
> +       "To calculate the sunrise and sunset times, you will need the date of your
> +observation and the geographical coordinates in latitude and longitude for the
> +location.")

How about this:

  (description
   "This package provides a Go library for calculating sunrise and
sunset times from geographical coordinates and a date.")

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..e697cd4af6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2485,6 +2485,33 @@  (define-public go-gopkg-in-go-playground-validator-v9
 @end itemize")
     (license license:expat)))
 
+(define-public go-github-com-nathan-osman-go-sunrise
+  (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
+        (revision "0"))
+    (package
+      (name "go-github-com-nathan-osman-go-sunrise")
+      (version (git-version "1.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nathan-osman/go-sunrise")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "017zwzx05r5spxcs07dp6bnh7waknzsd819k7aqd8kr819v3x9in"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/nathan-osman/go-sunrise"))
+      (home-page "https://github.com/nathan-osman/go-sunrise")
+      (synopsis "Calculates the sunrise and sunset times for a given location")
+      (description
+       "To calculate the sunrise and sunset times, you will need the date of your
+observation and the geographical coordinates in latitude and longitude for the
+location.")
+      (license license:expat))))
+
 (define-public go-github-com-aws-sdk
   (package
     (name "go-github-com-aws-sdk")