diff mbox series

[bug#59399,4/4] gnu: Add hebcal.

Message ID 20221120134802.19051-4-felix.lechner@lease-up.com
State New
Headers show
Series [bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Nov. 20, 2022, 1:48 p.m. UTC
* gnu/packages/calendar.scm (hebcal): New variable.
---
 gnu/packages/calendar.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

\( Nov. 20, 2022, 2:06 p.m. UTC | #1
On Sun Nov 20, 2022 at 1:48 PM GMT, Felix Lechner wrote:
> * gnu/packages/calendar.scm (hebcal): New variable.

> --- a/gnu/packages/calendar.scm
> +++ b/gnu/packages/calendar.scm

> @@ -426,3 +428,37 @@ (define-public gsimplecal

> +      (build-system go-build-system)
> +      (arguments
> +       '(#:import-path "github.com/hebcal/hebcal"))

  (list ...)

> +      (native-inputs
> +       (list go-github-com-hebcal-hebcal-go
> +             go-github-com-pborman-getopt))

I think these both need to be regular inputs.

> +      (synopsis "Perpetual Jewish Calendar with holidays and prayer times")

  (synopsis "Perpetual Jewish calendar program")

> +      (description "Hebcal is a program which converts between Hebrew and Gregorian
> +dates, and generates lists of Jewish holidays for any year past, present or future.
> +Shabbat and holiday candle lighting and havdalah times are approximated based on
> +location.
> +
> +It can also show daily prayer times, the weekly Torah reading (Parashat HaShavua)
> +and the daily leaf of Talmud (Daf Yomi).  The program can furthermore help with the
> +counting of the Omer or with the calculation of Hebrew yahrzeits, birthdays or
> +anniversaries.")

  (description
   "Hebcal is a program for converting between Hebrew and Gregorian
dates, and generating lists of Jewish holidays for a given year.
Shabbat, holiday candle lighting, and havdalah times are approximated
using your location.

It can also show daily prayer times, the weekly Torah reading, and
the daily leaf of Talmud.  The program can help with counting of the
Omer or with calculation of Hebrew yahrzeits, birthdays, or
anniversaries.")

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 6583810277..41c047f955 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -34,6 +34,7 @@  (define-module (gnu packages calendar)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages admin)
@@ -45,6 +46,7 @@  (define-module (gnu packages calendar)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages perl)
@@ -426,3 +428,37 @@  (define-public gsimplecal
 launched again it closes the running instance.  It can additionally be
 configured to show the current time in different timezones.")
       (license license:bsd-3))))
+
+(define-public hebcal
+  (let ((commit "2384bb88dc1a41a4a5ae57a29fb58b2dd49a475d")
+        (revision "0"))
+    (package
+      (name "hebcal")
+      (version (git-version "5.3.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/hebcal/hebcal")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "12rv3b51jb7wcjwmmizz9jkw7gh37yklys4xncvpzgxdkkfgmmjx"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/hebcal/hebcal"))
+      (native-inputs
+       (list go-github-com-hebcal-hebcal-go
+             go-github-com-pborman-getopt))
+      (synopsis "Perpetual Jewish Calendar with holidays and prayer times")
+      (description "Hebcal is a program which converts between Hebrew and Gregorian
+dates, and generates lists of Jewish holidays for any year past, present or future.
+Shabbat and holiday candle lighting and havdalah times are approximated based on
+location.
+
+It can also show daily prayer times, the weekly Torah reading (Parashat HaShavua)
+and the daily leaf of Talmud (Daf Yomi).  The program can furthermore help with the
+counting of the Omer or with the calculation of Hebrew yahrzeits, birthdays or
+anniversaries.")
+      (home-page "https://github.com/hebcal/hebcal")
+      (license license:gpl2+))))