diff mbox series

[bug#58768,2/9] gnu: Add go-github-com-jacobsa-crypto.

Message ID 20221025192727.2175-2-felix.lechner@lease-up.com
State New
Headers show
Series [bug#58768,1/9] gnu: Add go-github-com-hanwen-go-fuse-v2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Oct. 25, 2022, 7:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jacobsa-crypto): New variable.
---
 gnu/packages/golang.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1121674d20..35d6d0d329 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1170,6 +1170,37 @@  (define-public go-github-com-hanwen-go-fuse-v2
        "This is a repository containing Go bindings for writing FUSE file systems.")
       (license license:bsd-3))))
 
+(define-public go-github-com-jacobsa-crypto
+  (let ((commit "9f44e2d11115452dad8f404f029574422855f46a")
+        (revision "0"))
+    (package
+      (name "go-github-com-jacobsa-crypto")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jacobsa/crypto")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "18c3cx8izxdajq22zdq0n19j9d2l6iickd3mz39j5h96kw7l5qmy"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "github.com/jacobsa/crypto"
+             ;; Source-only package.
+             #:tests? #f
+             #:phases
+             #~(modify-phases %standard-phases
+                 ;; Source-only package.
+                 (delete 'build))))
+      (home-page "https://github.com/jacobsa/crypto")
+      (synopsis "Cryptography missing from the Go standard library")
+      (description
+       "This repository contains Go packages related to cryptographic standards that are
+not included in the Go standard library.")
+      (license license:asl2.0))))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")