diff mbox series

[bug#58768,1/9] gnu: Add go-github-com-hanwen-go-fuse-v2.

Message ID 20221025192727.2175-1-felix.lechner@lease-up.com
State New
Headers show
Series [bug#58768,1/9] gnu: Add go-github-com-hanwen-go-fuse-v2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Oct. 25, 2022, 7:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-hanwen-go-fuse-v2): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 348f70b9f429b19df6251a2c177291f4c606a495
prerequisite-patch-id: 11b4410d3ba809f1cf31d46f3f7fec85d8eab5c0
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d9b1b084b6..1121674d20 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1142,6 +1142,34 @@  (define-public go-github-com-operatorfoundation-shapeshifter-transports
 networks where it would otherwise be blocked or heavily throttled.")
     (license license:expat)))
 
+(define-public go-github-com-hanwen-go-fuse-v2
+  (let ((commit "4c25c9c1eecefb8beeea3daddf3486eb1dd48b89")
+        (revision "0"))
+    (package
+      (name "go-github-com-hanwen-go-fuse-v2")
+      (version (git-version "2.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/hanwen/go-fuse")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0hi3x963bj9hcngyy2ba3mipcqx5gwqvcj7vg1r4vlal2qbsqcmf"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/hanwen/go-fuse/v2"))
+      (native-inputs (list
+                      go-golang-org-x-sys
+                      go-golang-org-x-sync
+                      go-github-com-kylelemons-godebug))
+      (home-page "https://github.com/hanwen/go-fuse")
+      (synopsis "Go bindings for FUSE filesystems")
+      (description
+       "This is a repository containing Go bindings for writing FUSE file systems.")
+      (license license:bsd-3))))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")