diff mbox series

[bug#58387,2/2] gnu: Add cobib. * gnu/packages/python-xyz.scm (python-cobib): New variable.

Message ID 20221009030224.10447-2-matf@disr.it
State Accepted
Headers show
Series Add cobib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Oct. 9, 2022, 3:02 a.m. UTC
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

\( Oct. 9, 2022, 8:37 a.m. UTC | #1
On Sun Oct 9, 2022 at 4:02 AM BST, M wrote:
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "cobib" version))

Add a file-name field here too, please.

> +    (propagated-inputs (list python-beautifulsoup4
> +                             python-bibtexparser
> +                             python-pylatexenc
> +                             python-requests
> +                             python-requests-oauthlib
> +                             python-ruamel.yaml))

Put the start of the list on a new line.

> +    (home-page "https://gitlab.com/mrossinek/cobib")
> +    (synopsis "Console bibliography")

Would "TUI bibliography management tool" be more precise?

> +     "@command{cobib} is a simple, command-line based bibliography management

Remove the ``simple'' adjective; we try to avoid marketing in descriptions to the
best of our ability.

> +tool.  It is the result of the need for an easy-to-use alternative to full-blown
> +reference managers like Mendeley or Zotero.  It uses a plain-text database,

For the same reason, could you remove the "It is the result ... or Zotero" line?

> +location-independent library, and features git integration, command-line

Maybe add "a" before "location-independent"?

> +support, as well as a curses-based TUI.")

s/as well as/and/ maybe?

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bb571c525c..feb187c515 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -552,6 +552,37 @@  (define-public python-cachetools
 @code{lru_cache} function decorator.")
     (license license:expat)))
 
+(define-public python-cobib
+  (package
+    (name "python-cobib")
+    (version "3.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cobib" version))
+              (sha256
+               (base32
+                "16nbrbvascbf6cb7yvn9q793dy8zx703pqrmk3mswib9a19mnx3n"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-beautifulsoup4
+                             python-bibtexparser
+                             python-pylatexenc
+                             python-requests
+                             python-requests-oauthlib
+                             python-ruamel.yaml))
+    (native-inputs
+     (list python-future
+           python-pyte
+           python-pytest))
+    (home-page "https://gitlab.com/mrossinek/cobib")
+    (synopsis "Console bibliography")
+    (description
+     "@command{cobib} is a simple, command-line based bibliography management
+tool.  It is the result of the need for an easy-to-use alternative to full-blown
+reference managers like Mendeley or Zotero.  It uses a plain-text database,
+location-independent library, and features git integration, command-line
+support, as well as a curses-based TUI.")
+    (license license:expat)))
+
 (define-public python-colorful
   (package
     (name "python-colorful")