diff mbox series

[bug#58387,1/2] gnu: Add python-pylatexenc. * gnu/packages/python-xyz.scm (python-pylatexenc): New variable.

Message ID 20221009030224.10447-1-matf@disr.it
State Accepted
Headers show
Series Add cobib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Oct. 9, 2022, 3:02 a.m. UTC
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

\( Oct. 9, 2022, 8:34 a.m. UTC | #1
Hey,

On Sun Oct 9, 2022 at 4:02 AM BST, M wrote:
> +    (name "python-pylatexenc")
> +    (version "2.10")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "pylatexenc" version))

Could you add a ``file-name'' field? Something like:

  (file-name (string-append name "-" version ".tar.gz"))

> +    (synopsis
> +     "Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion")
> +    (description
> +     "Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion")

You'll want to shorten the synopsis and make the description a full sentence.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 054bd3ed29..bb571c525c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1617,6 +1617,24 @@  (define-public python-hnswlib
 approximate nearest neighbor search with Python bindings.")
     (license license:asl2.0)))
 
+(define-public python-pylatexenc
+  (package
+    (name "python-pylatexenc")
+    (version "2.10")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pylatexenc" version))
+              (sha256
+               (base32
+                "1ls09z47b5md71gkxcj7fd87ynpvv2walgp2w6z31p26xf2gvn1x"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/phfaist/pylatexenc")
+    (synopsis
+     "Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion")
+    (description
+     "Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion")
+    (license license:expat)))
+
 (define-public python-pyls-black
   (package
     (name "python-pyls-black")