diff mbox series

[bug#57744,3/3] gnu: Add shirah.

Message ID 20220912001028.8375-3-matf@disr.it
State Accepted
Headers show
Series Add shirah and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Sept. 12, 2022, 12:10 a.m. UTC
* gnu/packages/ebook.scm (shirah): New variable.
---
 gnu/packages/ebook.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index be41318095..a5a19cb9c0 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -697,3 +697,24 @@  (define-public python-ebooklib
     (description "Ebook library which can handle EPUB2/EPUB3 and Kindle
 format.")
     (license license:agpl3)))
+
+(define-public shirah
+  (package
+    (name "shirah")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "shirah_reader" version))
+              (sha256
+               (base32
+                "0j15v435lz68c1mj5clfx5dmfyjc6jvvz2q8hqvv799mb2faj42y"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-beautifulsoup4 python-ebooklib
+                             python-syllables python-termcolor))
+    (home-page "https://github.com/hallicopter/shirah-reader")
+    (synopsis "A curses based terminal ebook reader with optional RSVP mode")
+    (description "@command{shirah} is a curses based terminal ebook reader that
+can display ebooks in the usual way or with Rapid Serial Visual Presentation, a
+method to enable speedreading by showing the text word by word at configurable
+speeds.")
+  (license license:expat)))