diff mbox series

[bug#57678,2/2] gnu: Add r-ggalt.

Message ID 20220908145656.1720814-2-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r-ggalt and r-proj.4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Sept. 8, 2022, 2:56 p.m. UTC
* gnu/packages/cran.scm (r-ggalt): New variable.
---
 gnu/packages/cran.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab12c80a79..662d385d6f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -422,6 +422,49 @@  (define-public r-emdist
 Distance (EMD).")
     (license license:expat)))
 
+(define-public r-ggalt
+  (package
+    (name "r-ggalt")
+    (version "0.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "ggalt" version))
+              (sha256
+               (base32
+                "0ssa274d41vhd6crzjz7jqzbwgnjimxwxl23p2cx35aqs5wdfjpc"))))
+    (properties `((upstream-name . "ggalt")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ash
+           r-dplyr
+           r-extrafont
+           r-ggplot2
+           r-gtable
+           r-kernsmooth
+           r-maps
+           r-mass
+           r-plotly
+           r-proj.4
+           r-rcolorbrewer
+           r-scales
+           r-tibble))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/hrbrmstr/ggalt")
+    (synopsis
+     "Geometries, coordinate systems, fonts and more for ggplot2")
+    (description
+     "This package provides a compendium of new geometries, coordinate systems,
+statistical transformations, scales and fonts for ggplot2, including splines,
+1d and 2d densities, univariate average shifted histograms, a new map
+coordinate system based on the PROJ.4-library along with
+@code{geom_cartogram()} that mimics the original functionality of
+@code{geom_map()}, formatters for \"bytes\", a @code{stat_stepribbon()}
+function, increased @code{plotly} compatibility and the @code{StateFace} open
+source font ProPublica.  Further new functionality includes lollipop charts,
+dumbbell charts, the ability to encircle points and coordinate-system-based
+text annotations.")
+    (license license:agpl3)))
+
 (define-public r-glmpca
   (package
     (name "r-glmpca")