diff mbox series

[bug#57678,1/2] gnu: Add r-proj.4.

Message ID 20220908145656.1720814-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add r-ggalt and r-proj.4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Sept. 8, 2022, 2:56 p.m. UTC
* gnu/packages/cran.scm (r-proj.4): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7aa3ebde97..ab12c80a79 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -593,6 +593,29 @@  (define-public r-googlesheets4
 can read and write both the metadata and the cell data in a Sheet.")
     (license license:expat)))
 
+(define-public r-proj.4
+  (package
+    (name "r-proj.4")
+    (version "1.0-11")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "proj4" version))
+              (sha256
+               (base32
+                "07fil52jswbg2h807cd82m2wlm5j2fb891ifri9ms037099qdwf5"))))
+    (properties `((upstream-name . "proj4")))
+    (build-system r-build-system)
+    (inputs (list proj.4 zlib))
+    (native-inputs (list pkg-config))
+    (home-page "http://www.rforge.net/proj4/")
+    (synopsis "Simple interface to the PROJ.4 cartographic projections library")
+    (description
+     "This package provides a simple interface to lat/long projection and
+datum transformation of the PROJ.4 cartographic projections library.  It
+allows transformation of geographic coordinates from one projection and/or
+datum to another.")
+    (license license:gpl2)))
+
 (define-public r-waldo
   (package
     (name "r-waldo")