@@ -2213,7 +2213,13 @@ (define libstdc++-boot0
(lambda _
(substitute* "libstdc++-v3/configure"
(("g\\+\\+ -v") "true"))))))))
- (_ (package-arguments lib)))))
+ (_ (package-arguments lib)))
+
+ ;; Explicitly add #:modules so MAKE-LIBSTDC++ can be changed
+ ;; without a full bootstrap.
+ #:modules ((guix build gnu-build-system)
+ (guix build utils))))
+
(inputs (%boot0-inputs))
(native-inputs '()))))
@@ -2266,7 +2272,18 @@ (define gcc-boot0
(inherit gcc)
(name "gcc-cross-boot0")
(outputs (delete "debug" (package-outputs gcc)))
- (source (bootstrap-origin (package-source gcc)))
+ (source
+ (bootstrap-origin
+ (origin
+ (inherit (package-source gcc))
+ (snippet
+ #~(begin
+ ;; XXX: The GCC test suite contains files with non-ASCII file
+ ;; names, which cannot be repacked by BOOTSTRAP-ORIGIN. Nor
+ ;; can it be deleted from Guile, so resort to this evil hack.
+ #$(origin-snippet (package-source gcc))
+ (system* #$(file-append coreutils-boot0 "/bin/rm") "-rf"
+ "gcc/testsuite/go.test/test/fixedbugs/issue27836.dir"))))))
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
@@ -2991,7 +3008,7 @@ (define binutils-final
(define libstdc++
;; Intermediate libstdc++ that will allow us to build the final GCC
;; (remember that GCC-BOOT0 cannot build libstdc++.)
- (let ((lib (make-libstdc++ gcc)))
+ (let ((lib (make-libstdc++ gcc-boot0)))
(package
(inherit lib)
(source (bootstrap-origin (package-source lib)))
@@ -3059,6 +3076,11 @@ (define gcc-final
;; positive, so turn it off.
#:validate-runpath? #f
+ ;; Additional modules for the libstdc++ phase below.
+ #:modules ((srfi srfi-1)
+ (srfi srfi-26)
+ ,@%gnu-build-system-modules)
+
,@(substitute-keyword-arguments (package-arguments gcc)
((#:make-flags flags)
;; Since $LIBRARY_PATH is not honored, add the relevant flags.
@@ -3096,7 +3118,26 @@ (define gcc-final
(package-full-name lib "-")
char-set:letter)
,(package-name lib)))
- (list gmp-6.0 mpfr mpc))))))))))
+ (list gmp-6.0 mpfr mpc)))))
+ (add-after 'unpack 'fix-build-with-external-libstdc++
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libstdc++ (assoc-ref inputs "libstdc++")))
+ ;; Fix a regression in GCC 11 where the libstc++ input
+ ;; shadows glibc headers when building libstdc++. An
+ ;; upstream fix was added in GCC 11.3.0, but it only
+ ;; hides system include directories, not those on
+ ;; CPLUS_INCLUDE_PATH. See discussion at
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100017>.
+ (substitute* "libstdc++-v3/src/c++17/Makefile.in"
+ (("AM_CXXFLAGS = ")
+ (string-append "CPLUS_INCLUDE_PATH = "
+ (string-join
+ (remove (cut string-prefix? libstdc++ <>)
+ (string-split
+ (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":")
+ "\nAM_CXXFLAGS = ")))))))))))
;; This time we want Texinfo, so we get the manual. Add
;; STATIC-BASH-FOR-GLIBC so that it's used in the final shebangs of
@@ -3407,10 +3448,10 @@ (define-public gcc-toolchain-9
(make-gcc-toolchain gcc-9))
(define-public gcc-toolchain-10
- gcc-toolchain)
+ (make-gcc-toolchain gcc-10))
(define-public gcc-toolchain-11
- (make-gcc-toolchain gcc-11))
+ gcc-toolchain)
(define-public gcc-toolchain-12
(make-gcc-toolchain gcc-12))
@@ -3418,7 +3459,7 @@ (define-public gcc-toolchain-12
(define-public gcc-toolchain-aka-gcc
;; It's natural for users to try "guix install gcc". This package
;; automatically "redirects" them to 'gcc-toolchain'.
- (deprecated-package "gcc" gcc-toolchain-10))
+ (deprecated-package "gcc" gcc-toolchain-11))
(define-public gdc-toolchain-10
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
@@ -718,7 +718,7 @@ (define-public gcc-12
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions.
-(define-public gcc gcc-10)
+(define-public gcc gcc-11)
;;;
@@ -821,8 +821,33 @@ (define-public (make-libstdc++ gcc)
(name "libstdc++")
(arguments
`(#:out-of-source? #t
+ #:modules ((srfi srfi-1)
+ (srfi srfi-26)
+ ,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
+ ,@(if (version>=? (package-version gcc) "11")
+ '((add-after 'unpack 'hide-gcc-headers
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref (or native-inputs inputs) "gcc")))
+ ;; Fix a regression in GCC 11 where the GCC headers
+ ;; shadows glibc headers when building libstdc++. An
+ ;; upstream fix was added in GCC 11.3.0, but it only
+ ;; hides system include directories, not those on
+ ;; CPLUS_INCLUDE_PATH. See discussion at
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100017>
+ ;; and the similar adjustment in GCC-FINAL.
+ (substitute* "libstdc++-v3/src/c++17/Makefile.in"
+ (("AM_CXXFLAGS = ")
+ (string-append "CPLUS_INCLUDE_PATH = "
+ (string-join
+ (remove (cut string-prefix? gcc <>)
+ (string-split
+ (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":")
+ "\nAM_CXXFLAGS = ")))))))
+ '())
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
(add-before 'chdir 'fix-rs6000-libdir
(lambda _
@@ -1109,7 +1134,7 @@ (define-public gcc-objc-12
(custom-gcc gcc-12 "gcc-objc" '("objc")
%objc-search-paths))
-(define-public gcc-objc gcc-objc-10)
+(define-public gcc-objc gcc-objc-11)
(define %objc++-search-paths
(list (search-path-specification
@@ -1159,7 +1184,7 @@ (define-public gcc-objc++-12
(custom-gcc gcc-12 "gcc-objc++" '("obj-c++")
%objc++-search-paths))
-(define-public gcc-objc++ gcc-objc++-10)
+(define-public gcc-objc++ gcc-objc++-11)
(define (make-libstdc++-doc gcc)
"Return a package with the libstdc++ documentation for GCC."